Back to overview
Resolved

Server Upgrade

Jul 29, 2026 at 5:02pm UTC  –  Jul 29, 2026 at 7:02pm UTC
Affected services
Pi

Resolved
Jul 29, 2026 at 7:02pm UTC

Maintenance ended

Created
Jul 29, 2026 at 5:02pm UTC

In-depth description of what's going on.